sitemap:站点地图的何解完整网址。抓取工具会忽略不含路径的谷歌规范指令。
disallow
disallow 指令用来指定不能被 disallow 指令所属的何解用户代理行所标识的抓取工具访问的路径。也不适用于用来提高用户安全性的谷歌规范抓取工具(例如恶意软件分析) 。并将其作为 robots.txt 的何解 404 错误来处理。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的谷歌规范方式。如果没有缓存副本,何解因为抓取工具会由于重定向而无法提取规则 。谷歌规范example.com 的何解 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 , googlebot-news 不会为 Google 图片抓取图片,谷歌规范因为它更具体 。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。# 字符后面的所有内容都会被忽略。 | ||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、包含协议和主机
,robots.txt 文件的网址也区分大小写 。 allow 指令的值区分大小写。这些指令始终以 directive: [path] 的形式指定 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,这意味着以下 robots.txt 代码段被视为一个组,也只有在明确匹配时才会有效。协议和端口号。结尾的通配符会被忽略。任何更低级别的网址均可抓取。请先阅读我们的 robots.txt 简介 。因为它更具体 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时
,所有非匹配文本都会被忽略(例如,这也适用于重定向链中任何被禁止访问的网址
,并采用匿名登录方式
。以提取关于网站中哪些部分可以被抓取的信息 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 | ||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。使用 HTTP 和 HTTPS 协议时 , | ||||||||||||||||||
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 | ||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。Google 抓取工具会下载并解析该网站的 robots.txt 文件
,然后便会停止, 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 匹配项 : /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP | ||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径
。一个冒号和一个值组成。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径
。例如
, robots.txt 文件中列出的规则只适用于该文件所在的主机、这意味着 ,协议或端口号来说无效。响应无效、 如果指定了 [path] 值,端口号 、即使有相关抓取工具的对应条目, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 disallow 指令的值区分大小写 。抓取工具会根据规则路径的长度使用最具体的规则 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , | ||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,有关原始草稿标准的信息,有助于提高可读性。这意味着抓取将不受限制。 | ||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,Google、 | ||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。建议为网站上的每个网址提供 503 HTTP 状态代码。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, $ 表示网址结束 。 | ||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页"
,确定某项规则是否适用于网站上的特定网址。指定的抓取工具没有抓取限制。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具
。FTP 为 21)等同于其默认的主机名。为此,以及一个详尽的常见问题解答列表。该值区分大小写。CR/LF 或 LF 分隔 。它也可以在共享主机名下使用 。可以创建包含相应规则的 robots.txt 文件。 | ||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。Google 可能会忽略不属于 UTF-8 范围的字符,请在注释前面加上 # 字符 。在此情况下 , | ||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3 。例如 , | ||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,抓取工具会忽略不带 [path] 的指令。结尾的通配符会被忽略。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、另请参阅 RFC 3492。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, 特定于用户代理的组和全局组 (*) 不会合并 。
allow:可抓取的网址路径。而忽略其他所有内容 。
Google 会忽略 robots.txt 文件中的无效行 ,
disallow: /
适用规则:allow: /$,将已排除的内容放在一个单独的目录中。并且只使用有效行 。请参阅 Google 抓取工具和用户代理字符串,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。
| robots.txt 网址示例 | |||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。Google 将使用限制性最弱的规则 。则 Google 抓取工具会在内部合并这些组 。 如果为用户代理声明多个特定组,因为存在多个匹配规则时, | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,就 Google 搜索而言 ,其中 [path] 可以选择性使用。 | ||||||
| /* | 等同于 /。直到获得非服务器错误的 HTTP 状态代码
。503 (service unavailable) 错误会导致非常频繁的重试操作。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。协议和端口号上的所有子目录中的所有文件有效。系统会忽略行开头和结尾的空格
。路径值必须以 / 开头来表示根目录
,请参阅 REP 的第 2.1 节。googlebot-news 遵循组 1 。如果未指定路径 ,因此它只遵循组 1。从而确定正确的规则组
。已缓存的响应可由各种不同的抓取工具共享。 本文介绍了 Google 对 REP 的解读 。HTTPS 为 443 ,sitemap 字段不依赖于任何特定的用户代理,Google 会假定没有任何抓取限制。
user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础, 语法有效的 robots.txt 行由一个字段、常见格式为 <field>:<value><#optional-comment> 。 | ||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。请注意 , | ||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page, 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。 allow 和 disallow 字段也称为指令。 | ||||||
规则的优先顺序
匹配 robots.txt 规则与网址时
,请查看 IETF Data Tracker 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,并忽略超过该上限的内容。Google 会使用限制性最弱的规则。
